373 New Articles

Φροντιστήριο Μ. Ε. ΘΕΜΕΛΙΟ Πύργου - Πανελλαδικές εξετάσεις - Τα θέματα και οι απαντήσεις στο μάθημα της Ανάπτυξης Εφαρμογών σε προγραμματιστικό περιβάλλον προσανατολισμού της Γ΄ τάξης των Ημερήσιων ΓΕΛ

Φροντιστήριο Μ. Ε. ΘΕΜΕΛΙΟ Πύργου - Πανελλαδικές εξετάσεις - Τα θέματα του μαθήματος της Ανάπτυξης Εφαρμογών σε προγραμματιστικό περιβάλλον προσανατολισμού της Γ΄ τάξης των Ημερήσιων ΓΕΛ - Σύντομα και οι απαντήσεις

Ελλάδα
Typography
  • Smaller Small Medium Big Bigger
  • Default Helvetica Segoe Georgia Times

ΑΠΑΝΤΗΣΕΙΣ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ΄ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΛΥΚΕΙΟΥ

 

ΘΕΜΑ Α

 

Α1.

Σωστό

Λάθος

Λάθος

Σωστό

Λάθος

 

A2.

(Σχολικό βιβλίο σελ. 56)

ΕΙΣΑΓΩΓΗ : Είναι η προσθήκη νέων κόμβων σε μια υπάρχουσα δομή δεδομένων.

ΔΙΑΓΡΑΦΗ : Είναι η αφαίρεση (εξαγωγή) ενός κόμβου ή κόμβων από μια δομή δεδομένων.

ΑΝΑΖΗΤΗΣΗ : Είναι η προσπέλαση των κόμβων μίας δομής δεδομένων με σκοπό να βρεθούν ένας ή περισσότεροι κόμβοι με συγκεκριμένη ιδιότητα.

ΤΑΞΙΝΟΜΗΣΗ : Διάταξη των κόμβων της δομής κατά αύξουσα ή φθίνουσα σειρά.

 

Α3.

α) Θα εμφανίσει 6,8 , 10. β) Θα εμφανίσει 7. γ) Θα εμφανίσει 1 , 3.

 

A4.

ΟΣΟ: Σχολικό βιβλίο σελ. 44

ΜΕΧΡΙΣ_ΟΤΟΥ: Σχολικό βιβλίο σελ. 46

 

 

 

Α5.

ΑΡΧΗ

Ρß0

ΟΣΟ Μ2>0 ΕΠΑΝΑΛΑΒΕ

   ΑΝ Μ2 mod 2=1 ΤΟΤΕ

 PßP+M1

   ΤΕΛΟΣ_ΑΝ

   Μ1çΜ1*2

   Μ2ßΜ2 div 2

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ Ρ

 

 

ΘΕΜΑ Β

Β1.

(1) 0 (2) n (3) ψευδής (4) i (5) count + 1 (6)3 (7)αληθής (8) position (9) i + 1 (10)count = 3 , δεκτό και done = αληθής

 

Β2.

α)

Το υ είναι μεταβλητή ενώ το Ψ[10] είναι πίνακας.

Η συνάρτηση δεν καλείται με την εντολή ΚΑΛΕΣΕ.

Το πλήθος των πραγματικών και των τυπικών παραμέτρων είναι διαφορετικό.

Στην εντολή εκχώρησης τα δύο μέλη είναι διαφορετικού τύπου.

Ο τρόπος κλήσης της διαδικασίας είναι λάθος.

β)

π ßΑ ( κ , θ )

γ ßΑ ( μ , θ )

ΚΑΛΕΣΕ Β ( π , μ , γ )

π ßΑ ( μ , θ )

ΚΑΛΕΣΕ Β ( π , μ , ρ [ 1 ] )

 

 

ΘΕΜΑ Γ

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Γ

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: Ι, ΠΛ1, ΠΛ2, ΠΛ3, ΜΑΧ, ΜΕΓ, ΑΡ

ΧΑΡΑΚΤΗΡΕΣ: ΤΙΤΛ, ΟΝ_ΜΑΧ, ΟΝ_ΜΕΓ

ΑΡΧΗ

ΠΛ1 ß 0

ΠΛ2 ß 0

ΠΛ3 ß 0

ΜΑΧ ß -1

ΔΙΑΒΑΣΕ ΤΙΤΛ

ΟΣΟ ΤΙΤΛ <> 'ΤΕΛΟΣ' ΕΠΑΝΑΛΑΒΕ

ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

ΔΙΑΒΑΣΕ ΑΡ

ΜΕΧΡΙΣ_ΟΤΟΥ ΑΡ >=0

ΑΝ ΑΡ > 0 ΚΑΙ ΑΡ <= 100 ΤΟΤΕ

ΠΛ1 ß ΠΛ1 + 1

ΑΛΛΙΩΣ_ΑΝ ΑΡ > 100 ΚΑΙ ΑΡ <= 1000 ΤΟΤΕ

      ΠΛ2 ΠßΛ2 + 1

ΑΛΛΙΩΣ_ΑΝ ΑΡ > 1000 ΤΟΤΕ

ΠΛ3 ß ΠΛ3 + 1

ΤΕΛΟΣ_ΑΝ

ΑΝ ΑΡ > ΜΑΧ ΤΟΤΕ

ΜΑΧ ß ΑΡ

ΟΝ_ΜΑΧ ß ΤΙΤΛ

ΤΕΛΟΣ_ΑΝ

ΔΙΑΒΑΣΕ ΤΙΤΛ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ 'ΧΑΜΗΛΗ', ΠΛ1

ΓΡΑΨΕ 'ΜΕΣΑΙΑ', ΠΛ2

ΓΡΑΨΕ 'ΥΨΗΛΗ', ΠΛ3

ΓΡΑΨΕ 'Το βίντεο με το μεγαλύτερο αριθμό επισκέψεων είναι', ΟΝ_ΜΑΧ

ΜΕΓ ß ΠΛ1

ΟΝ_ΜΕΓ ß 'ΧΑΜΗΛΗ

ΑΝ ΠΛ2 > ΜΕΓ ΤΟΤΕ

 ΜΕΓ ß ΠΛ2

ΟΝ_ΜΕΓ ß 'ΜΕΣΑΙΑ'

ΤΕΛΟΣ_ΑΝ

ΑΝ ΠΛ3 > ΜΕΓ ΤΟΤΕ

 ΜΕΓ ß ΠΛ3

                   ΟΝ_ΜΕΓ ß 'ΥΨΗΛΗ'

ΤΕΛΟΣ_ΑΝ

ΓΡΑΨΕ 'Η κατηγορία', ΟΝ_ΜΕΓ, 'είχε τα περισσότερα βίντεο'

ΤΕΛΟΣ ΠΡΟΓΡΑΜΜΑΤΟΣ

 

 

ΘΕΜΑ Δ

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Δ

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: Ι, Κ, ΒΑΘΜΟΣ, ΑΡ, ΚΩΔ, ΒΑΘ[40,6], ΣΒ[40], Τ1

ΧΑΡΑΚΤΗΡΕΣ: ΟΝ[40], ΑΠ, Τ2

ΑΡΧΗ

ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 40

ΔΙΑΒΑΣΕ ΟΝ[Ι]

ΓΙΑ Κ ΑΠΟ  1 ΜΕΧΡΙ  6

ΒΑΘ[Ι,Κ] ß0 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

    ΔΙΑΒΑΣΕ ΚΩΔ, ΑΡ,ΒΑΘΜΟΣ

    ΑΝ ΒΑΘΜΟΣ > ΒΑΘ[ΚΩΔ,ΑΡ] ΤΟΤΕ

        ΒΑΘ[ΚΩΔ,ΑΡ] ß ΒΑΘΜΟΣ

    ΤΕΛΟΣ_ΑΝ

    ΓΡΑΨΕ 'Υπάρχει νέα λύση προβλήματος; ΝΑΙ/ΟΧΙ'

    ΔΙΑΒΑΣΕ ΑΠ

ΜΕΧΡΙΣ_ΟΤΟΥ ΑΠ = 'ΟΧΙ'

ΚΑΛΕΣΕ ΥΣΒ(ΒΑΘ,ΣΒ)

ΓΙΑ Κ ΑΠΟ 2 ΜΕΧΡΙ 40

ΓΙΑ Ι ΑΠΟ 40 ΜΕΧΡΙ Κ ΜΕ_ΒΗΜΑ -1

ΑΝ ΣΒ[Ι-1] < ΣΒ[Ι]ΤΟΤΕ

Τ1 ß ΣΒ[Ι-1]

ΣΒ[Ι-1] ß ΣΒ[Ι]

ΣΒ[Ι] ß Τ1

Τ2 ß ΟΝ[Ι-1]

ΟΝ[Ι-1] ß ΟΝ[Ι]

ΟΝ[Ι] ß Τ2

  ΑΛΛΙΩΣ_ΑΝ ΣΒ[Ι-1] = ΣΒ[Ι] ΤΟΤΕ

ΑΝ ΟΝ[Ι-1] > ΟΝ[Ι] ΤΟΤΕ

Τ2 ß ΟΝ[Ι-1]

ΟΝ[Ι-1] ß ΟΝ[Ι]

ΟΝ[Ι] ß Τ2

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΑΝ

     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ             

ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 40        

ΓΡΑΨΕ ΟΝ[Ι]         

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

ΔΙΑΔΙΚΑΣΙΑ ΥΣΒ(ΒΑΘ,ΣΒ) ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: ΒΑΘ[40,6],ΣΒ[40], Ι,Κ

ΑΡΧΗ

       ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 40

ΣΒ[Ι] ß 0

 ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 6

      ΣΒ[Ι] ß ΣΒ[Ι] + ΒΑΘ[Ι,Κ]

             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

       ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ ΔΙΑΔΙΚΑΣΙΑΣ

 

 

ΕΠΙΜΕΛΕΙΑ ΑΠΑΝΤΗΣΕΩΝ:

   ΘΕΩΝΗ ΔΕΜΕΚΑ

ΚΑΘΗΓΗΤΡΙΑ ΠΛΗΡΟΦΟΡΙΚΗΣ

Εγγραφείτε προκειμένου να λαμβάνετε δωρεάν ειδοποιήσεις όταν έχουμε νεότερες πληροφορίες.